Simple NAT Configuration for Cisco Router

June 12, 2017 Jordansphere Cisco

The following configuration is for a NAT router which plugs into an Ethernet circuit.

The router is set to 192.168.1.1 and running DHCP

hostname CustomerA

ip dhcp pool LOCAL
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server  8.8.8.8
!
interface GigabitEthernet0/0
 description WAN 
 ip nat outside
 ip address 213.42.180.166 255.255.255.254
 duplex auto
 speed auto

interface GigabitEthernet0/1
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto


access-list 2 permit 192.168.1.0 0.0.0.255
access-list 50 permit 192.168.1.0 0.0.0.255
ip nat inside source list 2 interface GigabitEthernet0/0 overload


banner motd ^CCCCCCCCCCCCCCCC

-=[Unauthorized Access Prohibited]=-

^C
!
line con 0
 exec-timeout 0 0
 password 7 062E0A2D407D1D0AAA
 logging synchronous
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 access-class 50 in
 password 7 10660C1509240691E0
 logging synchronous
 login
 transport input all
!


 

Powered by WordPress. Designed by elogi.